


Volume: 39 Questions + 22 Chapter Labs + One Final Lab (include 21 task Labs) 
 
Lab1: Configuring Audit Settings on Red Hat 
Lab2: Configuring Audit Settings for STIG Compliance on Red Hat 
Lab3: Run an OpenSCAP Compliance Scan on a Host 
Lab4: Creating a Custom Scan Policy with OpenSCAP 
Lab5: Performing a Compliance Scan and Active Remediation Using OSCAP 
Lab6: Getting Started with Ansible 
Lab7: Ansible Playbooks - the Basics 
Lab8: Installing and Configuring AIDE 
Lab9: Managing SSH Access 
Lab10: Installing and Configuring USBGuard 
Lab11: Creating USBGuard Rules 
Lab12: Configure an Account Lockout Policy 
Lab13: Configure a Password Complexity Policy 
Lab14: Managing sudo Access 
Lab15: Creating a New Encrypted Volume Using LUKS 
Lab16: Changing a LUKS Passphrase 
Lab17: Creating a Secondary LUKS Passphrase and LUKS Header Backup 
Lab18: Encrypting a Volume with NBDE 
Lab19: Configuring SELinux 
Lab20: Creating Confined Users in SELinux 
Lab21: Troubleshooting SELinux 
Lab22: Granting sudo Privileges to Confined Users 
Final Lab: 21 task labs 
 
 
Question No: 1 
Which command is used to install a client that will optimize a server for availability, stability, performance, and 
security for a server? 
A. yum install insights-client 
B. yum install scap-security-guide 
C. yum install -y scap-workbench 
D. apt-get install insights-client 
Answer: A 
Explanation: The yum install insights-client command is used to download the Red Hat Insights client on a 
server. Insights is used for optimization of availability, stability, performance, and security for a server. 
 
Question No: 2 
After AIDE is installed and configured, what are the steps to test AIDE's functionality? Choose 4 
A. Create a new file 
B. run AIDE's --check command 
C. rename the AIDE database 
D. Restart the system to initialize changes to the AIDE environment 



E. Build the initial database 
F. run AIDE's --update command 
Answer: A,B,C,F 
Explanation: The first step, in testing AIDE is to create a file for the purpose of creating a change to the 
environment. 
After creating a file, running the --check command will compare the differences between the filesystem and 
the database. 
After initializing or updating the AIDE database, you must rename the AIDE database from 
/var/lib/aid/aide.db.new.gz to /var/lib/aid/aide.db.gz. 
After running a check, the --update command should be run to bring the database (baseline) up-to-date 
with the filesystem. 
 
Question No: 3 
Which non-persistent system call rule will write a log entry to the /var/log/audit/audit.log file whenever time 
is changed on the system? 
A. auditctl -a always,exit -F path=/etc/passwd -F perm=wa -F group=helpdesk -F user!=john 
B. auditctl -w /etc/passwd -p wa -k passwd_changes 
C. auditctl -w /etc/selinux -p wa -k selinux_rule 
D. auditctl -a always,exit -F arch=b64 -S adjtimex -S settimeofday -k time_change 
Answer: D 
Explanation: This is a system call rule (system call rules have the -a flag) will write a log entry to the 
/var/log/audit/audit.log file whenever time is changed on the system. 
 
Question No: 4 
Which are common use cases for using auditd? Choose 4 
A. to record all actions performed on a system 
B. monitors system calls or changes to the system 
C. recording what commands are run by a user 
D. monitors network access 
E. monitors file access 
F. provides an additional layer of security to your system 
Answer: A,B,C,D 
 
Question No: 5 
What symbol is used at the start of an Ansible playbook? 
A. Hashtag (#) 
B. Exclamation points (!) 
C. hosts: 
D. Dashes (---) 
Answer: D 
Explanation: Ansible playbooks uses three dashes (---) at the start of an Ansible playbook. 
 
Question No: 6 
Which directives should be used in the /etc/audit/auditd.conf file to set up a low disk space email alert? 



Choose 3 
A. action_mail_account 
B. space_left_action 
C. space_left 
D. max_log_file 
E. log_file 
Answer: A,B,C 
Explanation: Use the action_mail_account directive to set the email address that the disk space alert should 
be sent to. 
Set the space_left_action to define what action should occur when the space_left threshold is met. In this case, 
the space_left_action should be set to email. 
Set the space_left directive to define the alert threshold. The space_left directive defines how much open disk 
space should be left on a system. 
 
Question No: 7 
Which is a web-based UI system management solution that enables you to schedule policy scans, generate 
reports, and remediates systems from one centralized dashboard? 
A. OSCAP Workbench 
B. Red Hat Satellite 
C. the oscap command 
D. Red Hat Insight 
Answer: B 
Explanation: Red Hat Satellite is a web-based system management solution that provides scheduled policy 
scans, generates reports, and remediates systems for multiple Red Hat Enterprise Linux deployments within a 
single, centralized tool. 
 
Question No: 8 
What ordered steps are needed before the control node can communicate with its managed hosts? 
A. Install Ansible, generate SSH keys for the ansible user, copy the keys to the managed hosts, and update 
only one of the managed host's visudo file to grant sudo permissions to the Ansible user. 
B. Install Ansible, generate SSH keys for the ansible user, and update only one of the managed host's visudo 
file to grant sudo permissions to the ansible user. 
C. Install Ansible, generate SSH keys for the Ansible user, copy the keys to the managed hosts, and update 
each managed host's visudo file to grant sudo permissions to the Ansible user. 
D. Install Ansible, generate SSH keys for the ansible user, and update each managed host's visudo file to grant 
sudo permissions to the Ansible user. 
Answer: C 
Explanation: These are ordered steps needed before the control node can communicate with its managed 
hosts. 
 
Question No: 9 
OpenSCAP is a tool used to perform automated compliance audits. Which OpenSCAP component provides 
collections of security policies for Linux systems based on regulartory and government requirements? 
A. SCAP Workbench 



B. Script Check Engine (SCE) 
C. SCAP Security Guide (SSG) 
D. oscap 
Answer: C 
Explanation: This component of OpenSCAP provides pre configured rule sets and templates based on 
regulatory and government requirements. 
 
Question No: 10 
What tasks can Ansible perform on a server? Choose 3 
A. monitors system calls or changes to the system 
B. install/uninstall packages 
C. perform security audits 
D. edit files 
E. install patches 
Answer: B,D,E 
Explanation: Ansible can be used to install/uninstall packages. 
Ansible can be used to edit files. 
Ansible can be used to install patches. 
 
Question No: 11 
Which file is used to store and define persistent rules for auditd? 
A. /usr/share/doc/audit-version/rules 
B. /etc/audit/audit.conf 
C. /var/log/audit 
D. /etc/audit/audit.rules 
Answer: D 
Explanation: This file is where persistent rules must be created or edited for auditd. 
 
Question No: 12 
Which commands are needed to create keys for the Ansible user? Choose 2 
A. ssh-keygen 
B. su - ansible 
C. yum install ansible-agent 
D. ssh <target> 
E. ssh-copy-id <target> 
Answer: A,B 
Explanation: After switching to the ansible user, use the ssh-keygen command to generate SSH keys. 
To create keys for the ansible user you must first switch users. Switching to the ansible user is also needed for 
running ad-hoc Ansible commands and playbooks. 
 
Question No: 13 
Assuming our playbook is named remediation and in our present directory, which example command is used 
to run an Ansible playbook? Choose 2 
A. ansible-playbook remediation.html 



During AIDE's configuration, update the /etc/aide.conf file to enable reporting and specify where the report 
should be sent. 
During AIDE's configuration, the database should be copied from its default file of /var/lib/aid/aide.db.new.gz 
to /var/lib/aid/aide.db.gz. 
During AIDE's configuration, you must first build the initial database. 
 
Question No: 37 
Which default AIDE rule group will monitor sensitive files for all changes, except for file hash changes? 
A. EVERYTHING 
B. STATIC 
C. DIR 
D. PERMS 
Answer: C 
Explanation: AIDE's DIR rule group will monitor directories for all file changes, except for hash changes. 
 
Question No: 38 
What is a common error when dealing with AIDE? 
A. After running the --init command the error of, "Couldn't find file" is displayed. 
B. After running the --check command, the error of, "Couldn't open file" is displayed. 
C. After running the --check command the error of, "Couldn't find file" is displayed. 
D. After running the --init command the error of, "Couldn't find file" is displayed. 
Answer: B 
Explanation: After running the --check command, you may receive an error stating it couldn't open the 
database file. Remember, the database file holds the baseline data for your system and it needs to be 
initialized and renamed from aide.db.new.gz to aide.db.gz. 
 
Question No: 39 
Which rules are included in the AIDE's default DIR rule group? 
A. selinux+xattrs 
B. p+u+g+acl 
C. p+i+n+u+g 
D. p+i+n+u+g+acl+selinux+xattrs 
Answer: D 
Explanation: The default DIR rule group monitors: p (permissions), i (inode), n (number of links), u (user), g 
(Group), acl (Access Control Lists), selinux (SELinux security context), and xattrs (Extended files attributes). 
 
 
Lab1: Configuring Audit Settings on Red Hat 
 
Introduction 
 
In this lab, we will take a look at setting up auditing services on a Red Hat host. We will configure low space 
email alerting, limit logging space used, and limit the number of audit buffers. 
 



Solution 
 
1. Begin by logging in to the lab server using the credentials provided on the hands-on lab page: 
ssh cloud_user@PUBLIC_IP_ADDRESS 
 
2. Become the root user: 
sudo su 
 
Configure the auditd service to start automatically at boot 
 
1. Run the following command to ensure auditd starts automatically at boot: 
systemctl enable auditd 
 
2. Set up low disk space email alerts 
 
3. Edit the /etc/audit/auditd.conf file and set: 
space_left = 100 
space_left_action = email 
 
4. Restrict the disk space used by the audit logs 
 
5. Edit the /etc/audit/auditd.conf file and set the max_log_file and the num_logs values so their multiplied 
value is equal to 300 (MB). 
max_log_file = 10 
num_logs = 30 
 
6. Limit the number of audit buffers used by the system 
 
7. Edit the file /etc/audit/rules.d/audit.rules and set the buffer size: 
Change: -b 8192 
To: -b 5120 
 
8. Lastly, restart the auditd service 
service auditd restart 
 
 
Lab2: Configuring Audit Settings for STIG Compliance on Red Hat 
 
Introduction 
 
The Red Hat Linux audit service comes with precompiled rule sets for various compliance requirements. In 
this lab, we will configure a Red Hat host's audit rules to include the STIG (Security Technical Implementation 
Guide) compliance rule set. This will allow us to identify any points at which we are not compliant with STIG 
requirements. 



 
Solution 
 
1. Begin by logging in to the lab server using the credentials provided on the hands-on lab page: 
ssh cloud_user@PUBLIC_IP_ADDRESS 
 
2. Become the root user: 
sudo su 
 
Implement the Red Hat included STIG audit rules 
 
1. Make a backup of the current audit rules using the following command: 
cp /etc/audit/rules.d/audit.rules /etc/audit/rules.d/audit.rules_backup 
 
2. Copy the STIG audit rules into the audit.rules file with the following command: 
cd /usr/share/doc/audit-2.8.1/rules 
cat 30-stig.rules 99-finalize.rules >> /etc/audit/rules.d/audit.rules 
 
Restart the auditd service 
 
1. To restart the auditd service, use the following command: 
service auditd restart   
 
2. Run the following command to verify the status is active (running): 
service auditd status 
 
 
Lab3: Run an OpenSCAP Compliance Scan on a Host 
 
Introduction 
 
In this lab, we will be installing OpenSCAP and scanning a host for compliance. OpenSCAP is a powerful tool 
used to scan hosts to validate compliance with predetermined rule sets. This allows us to identify where we 
fall out of compliance and remediate the identified issues. 
 
Solution 
 
We will connect to our lab server using VNC. The IP address and credentials are provided in the hands-on lab 
page. 
 
VNC connections will be different for each operating system: 
 
 For Mac users: 

 Open Finder 



 Press Command+K on your keyboard to bring up the Connect to server window 
Alternatively, expand Go in the menu at the top of the screen and click Connect to Server 

 In the Connect to Server window, connect to vnc://<IP_ADDRESS>:5901, making sure to replace 
<IP_ADDRESS> with the IP address you are provided on the hands-on lab page 

 Windows users will need to install an application like VNC Viewer to connect. 
 
Install SCAP Workbench 
 
To install SCAP Workbench, run the following command from Terminal on the lab server: 
sudo yum install -y scap-workbench 
 
Scan the localhost for C2S compliance and create a report 
 
1. Open SCAP-Workbench 

Applications Menu -> System Tools -> SCAP Workbench 
 
2. Choose RHEL7 when prompted to Select content to load:, then click the Load Content button 
 
3. From the Profile drop down, select C2S for Red Hat Enterprise Linux 7 
 
4. Click the radial button next to Local Machine for the Target 
 
5. Click the Scan button at the bottom to start the scan 
 
6. Once the scan is complete click Close in the Diagnostics window 
 
7. Click the Save Results drop down button and select HTML Report 
 
8. Type "scan_results.html" in the name and click Save 
 
View the report 
Open Firefox on the lab server and navigate to file:///home/cloud_user/scan_results.html 
 
 
Lab4: Creating a Custom Scan Policy with OpenSCAP 
 
Introduction 
 
In this hands-on lab, we will use the SCAP Workbench tool to create a custom policy and scan a host with it. 
SCAP Workbench comes with preconfigured rule sets, from which we can create our own custom policies 
we'll use to scan our environment for compliance with internal security policies. 
 
Solution 
 



We will connect to our lab server using VNC. The IP address and credentials are provided in the hands-on lab 
page. 
 
VNC connections will be different for each operating system: 
 
 For Mac users: 

 Open Finder 
 Press Command+K on your keyboard to bring up the Connect to server window 

Alternatively, expand Go in the menu at the top of the screen and click Connect to Server 
 In the Connect to Server window, connect to vnc://<IP_ADDRESS>:5901, making sure to replace 

<IP_ADDRESS> with the IP address you are provided on the hands-on lab page 
 Windows users will need to install an application like VNC Viewer to connect. 
 
Create a Custom OpenSCAP Policy 
 
1. Open SCAP Workbench by navigating to Applications > System Tools > SCAP Workbench. 
 
2. Set Select content to load: to RHEL7. 
 
3. Click Load Content. 
 
4. Click the Customize button next to Profile. 
 
5. Provide a New Profile ID of "xccdf_org.ssgproject.custom_profile_1", and click OK. 
 
6. In the customizing window: 

 Click Deselect All at the top. 
 Under Services > Obsolete Services > Telnet, check the box next to Uninstall telnet-server 

Package. 
 Under Services > FTP Server > Disable vsftpd if Possible, check the box next to Uninstall vsftpd 

Package. 
 Under System Settings > Network Configurations and Firewalls > firewalld > Inspect and Activate 

Default firewalld Rules, check the boxes to Verify firewalld Enabled and Install firewalld. 
 
7. Click the OK button at the bottom of the customization window. 
 
8. In the SCAP Workbench window, navigate to File > Save Customization Only. 
 
9. Name the customization "custom_profile_1.xml", and click Save. 
 
Scan the Localhost with a Custom Profile 
 
1. In the SCAP Workbench window, set the Target to Local Machine. 
 



2. Click the Scan button at the bottom to start a scan using the custom profile. 
 
3. Once the scan finished, click the Close button in the Diagnostics window. 
 
4. Click Save Results at the bottom, and select HTML Report. 
 
5. Name the report "scan_results.html", and click Save. 
 
 
Lab5: Performing a Compliance Scan and Active Remediation Using OSCAP 
 
Introduction 
 
In this lab, we'll install and use openscap-scanner from the terminal. We'll run a compliance scan that uses 
active remediation and will permit OpenSCAP to fix any problems it finds. Then we'll create a report from the 
scan findings. Lastly, we'll review the report findings to see what OpenSCAP found and was able to remediate. 
 
Connecting to the Lab 
 
1. Open your terminal application, and run the following command (remember to replace <PUBLIC_IP> with 
the public IP you were provided on the lab instructions page): 
ssh cloud_user@<PUBLIC_IP> 
 
2. Enter yes at the prompt. 
 
3. Enter your cloud_user password at the prompt. 
 
4. Become root. 
sudo su  
 
Install the Necessary Packages 
 
Run the following command: 
yum install -y openscap-scanner scap-security-guide 
 
Run a Compliance Scan with Remediation 
 
Run the following command: 
oscap xccdf eval --remediate --profile xccdf_org.ssgproject.content_profile_rht-ccp --results scan-
results.xml /usr/share/xml/scap/ssg/content/ssg-rhel7-ds.xml 
 
Generate a Report from the Scan Results 
1. List the contents of the current directory. 
ls 




